第一章 简介

文章内容

TTM简介

注意事项

无

相关链接


1.1 TTM简介

文章内容

TTM是TTCN3 Test System Manager的缩写，即TTCN3测试系统管理器。

TTCN3是形式化的测试描述语言TTCN的最新版本，它在语法上作了重新设计，具有现代程序设计语言的风格，并增加了许多新特性，如测试执行控制机制、高并发度的动态测试配置、同步/异步通信功能以及模板匹配机制等，具有更强大的描述能力和更广泛的通用性，可以适应新的软件架构和下一代网络协议的测试需要。

TTM即是测试TTCN3语言的管理器。

注意事项

无

相关链接


1.2 TTM主要功能

文章内容

工程管理功能：提供新建、保存、读取TTCN工程，加入、删除、编辑、打印TTCN3测试例，编译、执行测试例，日志输出及结果输出、测试例模块参数配置等功能。

编译功能：对输入的TTCN3文件进行编译，输出相应的CPP文件。

执行功能：将内部表示的TTCN3文件翻译成对应的CPP文件，调用第三方编译器编译生成对应的DLL文件,供测试管理模块调用。

编解码功能：实现ASN.1系列(BER、PER)的编解码功能。

SA、PA模块功能：系统适配器和平台适配器功能。

注意事项

无

相关链接


1.3 TTM操作界面

文章内容

菜单栏：提供基本的文件操作功能菜单和按钮

导航栏：显示文件的信息。

默认窗口为"FileView"，主要显示文件路径和文件名。

可切换为窗口"ModuleView"。主要显示文件中代码的各模块和元素列表。

界面如下所示：

没有打开文件的情况：

打开一个文件之后的情况：

输出框1：输出编译、链接、运行时，编译器的状态信息。在出错时，显示错误提示信息。
输出框2：输出运行时的log信息。
输出框3：输出运行时的系统的状态。

注意事项

无

相关链接


1.4 TTM体系结构

文章内容

上图为TTCN3测试系统总体框架图，其中测试管理即为TTM的主要工作。

注意事项

无

相关链接


1.4.1 TTC介绍

文章内容

TTC是TTCN3 Test System Compiler的缩写，即TTCN3测试系统编译器。

注意事项

无

相关链接


1.4.2 TTE介绍

文章内容

TTE是TTCN3 Test System Executor的缩写，即TTCN3测试系统执行机。

注意事项

无

相关链接


1.4.3 CD介绍

文章内容

CD是Code和Decode的缩写，即编解码。主要实现ASN.1系列(BER、PER)的编解码功能。

注意事项

无

相关链接


1.4.4 SA介绍

文章内容

SA是System Adapter的缩写，即系统适配器。主要处理与编译器相关的功能。

注意事项

无

相关链接


1.4.5 PA介绍

文章内容

PA是Platform Adapter的缩写，即平台适配器。主要处理与当前操作系统相关的功能。

注意事项

无

相关链接


第二章 安装TTM

文章内容

TTCN3帮助文档

注意事项

无

相关链接


2.1 软硬件需求

文章内容

PC机，内存方面没有特殊要求，操作系统Windows2000/XP标准配置即可。

注意事项

无

相关链接


2.2 安装流程

文章内容

注意事项

无

相关链接


2.3 卸载

文章内容

注意事项

无

相关链接


第三章 一个hello world的例子

文章内容

注意事项

无

相关链接


3.1 新建*.3mp文件

文章内容

首先右键点击控制台上的图标UntitledProject,选择弹出菜单的Add New File选项，如下：

在弹出的对话框输入文件名hellworld.3mp，选择文件保存路径，然后点击"确定"，如下：

在编辑框输入代码：

module hello_world
{
Control
{
log("hello world");
}
}

然后，选择"保存"。这样，一个新建的*.3mp文件就完成了。下面可以对文件进行编译、链接和运行。

注意事项

无

相关链接


3.2 编译文件

文章内容

点击"Build"，选择"Compile Project"，如下：

文件在正确编译通过后，会在下面的提示框出现下面的提示，如下所示：

注意事项

无

相关链接


3.3 链接文件

文章内容

点击"Build"，选择"Compile All"，如下：

文件在正确链接之后，在下面的提示框会出现如下提示：

如下图所示：

注意事项

无

相关链接


3.4 运行及查看结果

文章内容

点击"Build"，选择"Execute Control"，弹出如下对话框：

需要选择相应的模块名对应的dll文件。比如：我们的模块名是hello_world，我们需要选择上图中的TTCN3hello_world.dll，然后点击"打开"。

文件在正确运行之后，在下面的提示框会出现如下提示：

----------------------

04/02/07 10:15:34
(1):245156:3528:TciStartControl
(2):245187:3528:ComponentValue con,name:Control
(3):245187:3528:CreateControl
(4):245187:3528:ComponentEntity():id:0,cAlive:0
(5):245187:2808:Value::Stop in Control
(6):245187:2808:ID:0,Entity::Stop
(7):245187:2808:Value::Kill in Control
(8):245187:2808:ID:0,Entity::Kill
(9):245187:2808:Throw KillEx with 0
(10):245187:3528:TciStartControl will end
(11):245187:2808:ControlRunnable::run,catch KillEx with id:0
(12):245187:2808:RemoveComponent:0
(13):245187:2808:~ComponentEntity,ID:0
(14):245187:2808:~CmpEntity() Thread:00000000
(15):245187:2808:TimerHolder::Remove() 0
(16):245187:2808:TimerHolder::Remove() 0
(17):245187:2808:TimerHolder::Remove() 0 not exist!
(18):245187:2808:ComponentValue des,name:Control
(19):245187:2808:ComponentHolder::Reset
(20):245187:2808:ComponentHolder::Reset 0 Cmps
(21):245187:2808:TimerHolder::Reset
(22):245187:2808:TimerHolder::Reset 0 timers
(23):245187:2808:Control Part End
----------------------
04/02/07 10:20:54
(1):565421:3528:TciStartControl
(2):565421:3528:ComponentValue con,name:Control
(3):565421:3528:CreateControl
(4):565421:3528:ComponentEntity():id:0,cAlive:0
(5):565421:3528:TciStartControl will end
(6):565421:2580:Value::Stop in Control
(7):565421:2580:ID:0,Entity::Stop
(8):565421:2580:Value::Kill in Control
(9):565421:2580:ID:0,Entity::Kill
(10):565421:2580:Throw KillEx with 0
(11):565421:2580:ControlRunnable::run,catch KillEx with id:0
(12):565437:2580:RemoveComponent:0
(13):565437:2580:~ComponentEntity,ID:0
(14):565437:2580:~CmpEntity() Thread:00000000
(15):565437:2580:TimerHolder::Remove() 0
(16):565437:2580:TimerHolder::Remove() 0
(17):565437:2580:TimerHolder::Remove() 0 not exist!
(18):565437:2580:ComponentValue des,name:Control
(19):565437:2580:ComponentHolder::Reset
(20):565437:2580:ComponentHolder::Reset 0 Cmps
(21):565437:2580:TimerHolder::Reset
(22):565437:2580:TimerHolder::Reset 0 timers
(23):565437:2580:Control Part End

如下图所示：

在右侧的输出框会出现要输出的内容，如下所示：

注意事项

无

相关链接


第四章 用户操作指南

文章内容

注意事项

无

相关链接


4.1

CHMFactory 帮助系统

4.1 工具栏介绍

文章内容

刚开始打开TTM时，存在的四个菜单之一。

注意事项

无

相关链接


4.1.1.1 New

文章内容

功能是建立一个新的文本文件，默认名为TTCN_n.3mp（n为已建立的文件的个数）。

注意事项

无

相关链接


4.1.1.2 Open

文章内容

如上图所示，功能是打开一个 *.3mp文件

注意事项

无

相关链接


4.1.1.3 Close

文章内容

这个选项是在打开文件之后才会出现的选项，功能是关闭当前在最上层的一个文件

注意事项

无

相关链接


4.1.1.4 Save(Save As)

文章内容

如上图所示，Save ( Save As)用于保存你所编辑的文件。

注意事项

无

相关链接


4.1.1.5 Print

文章内容

包括Pring/Print Preview/Print SetUp，用于打印当前文件以及对打印选项的设置。

注意事项

无

相关链接


4.1.2 Edit

文章内容

常用工具栏之一，包括的选项如下所表示：

Undo 撤销前一步操作
Redo 重复前一步操作
Cut 剪切
Copy 复制
Paste 粘贴
Delete 删除
Select All 全选

注意事项

无

相关链接


4.1.3 Search

文章内容

Search也是常用选项之一:

Find 查找
Find Next 查找下一个
Replace 查找某字符并且替换成另一个字符
Goto 前往第N行

注意事项

无

相关链接


4.1.4 Project

文章内容

Project菜单如上图所示，共有8项

注意事项

无

相关链接


4.1.4.1 New Project

文章内容

点击New Project得到下面的图示:

我们建立了一个新的工程项目的名称是：project1
方便起见，我们建立的工程目录为C:\Documents and Settings\zjlxht\桌面
以后你所建立的文件均需要存放在这个目录下。

注意事项

无

相关链接


4.1.4.2 Close Project

文章内容

点击Close Project,关闭当前工程项目 。

注意事项

无

相关链接


4.1.4.3 Open Project

文章内容

打开一个已经建立的工程（文件）。

注意事项

无

相关链接


4.1.4.4 Save Project (Save Project As)

文章内容

保存当前工程文件的设置以及改动。

注意事项

无

相关链接


4.1.4.5 Add File To Project

文章内容

这个选项用于向当前工程添加文件。

注意事项

无

相关链接


4.1.4.6 Remove File

文章内容

这个选项用于从当前项目中删除你选中的文件。

注意事项

无

相关链接


4.1.4.7 Local Settings

文章内容

这个选项用于对TTM环境的设置，包括选择的告紧级别，日志语言，最大错误数等等，如下图所示：

注意事项

无

相关链接


4.1.5 Build

文章内容

用于编译工程以及文件的选项
Complie Project 编译当前工程
Complie All 编译所有文件
Execute Control 运行当前测试例
Rebuild Project And Execute 重新编译工程并运行

注意事项

无

相关链接


4.1.6 Option

文章内容

这个选项用于用户定义当前文件编辑器的视图以及断点的设置等，默认情况下，如上图所示，显示行号等等 ,还可以通过这个选项在文件中添加，寻找断点。

注意事项

无

相关链接


4.1.7 View

文章内容

这个选项用于用户定义编译器的各个项目（栏目），窗口的显示情况，默认情况下，如上图所示，显示工具栏，状态栏，工作空间栏
Clear OutPut1 清除OutPut1的输出
Clear OutPut2 清除OutPut2的输出

注意事项

无

相关链接


4.1.8 Window

文章内容

New Window 打开一个新的编辑窗口
Cascade 最小化当前编辑窗口
Tile 显示当前窗口的标题
Close All Documents 关闭所有的文件

注意事项

无

相关链接


4.1.9 Help

文章内容

显示关于此编译器的一些信息

注意事项

无

相关链接


4.1.10 图标功能说明

文章内容

工具栏图表如上所示,从坐往右依次是：
新建文件
打开文件
保存文件
剪切
复制
粘贴
编译当前工程
链接当前工程
运行测试例
分别用于定义当前编译器的视图，显示哪些窗口。
用于在文件中添加，删除，查找断点。

注意事项

无

相关链接


4.2.1 环境配置

文章内容

在第一次打开编译器的时候，需要配置TTCN3的文件目录。 首先，点击"Project"，选择"Local Settings"，如下：

弹出的对话框如下：

点击"Browse"，选择TTCN3项目路径。选择之后，点击"OK"，确定。 如果，此处不选择项目路径，在连接时，会出现下面的错误：

如下所示：

注意事项

无

相关链接


4.2.2 打开、移除或新建项目

文章内容

1.打开现有项目
首先右键点击控制台上的图标UntitledProject,选择弹出菜单的Add Existed Files选项，如下：

弹出的对话框如下所示：

在上面的对话框选择已有的文件，然后点击打开，编译器就会打开这个文件，如下所示：

2.新建项目
首先右键点击控制台上的图标UntitledProject,选择弹出菜单的Add New File选项，如下：

在弹出的对话框输入文件名*.3mp，选择文件保存路径，然后点击"确定"，如下：

在编辑框输入代码。然后，选择"保存"。这样，一个新建的*.3mp文件就完成了。

3.移除项目
首先右键点击控制台上的图标UntitledProject,选择弹出菜单的Add New File选项，如下：

然后，编译器会弹出一个对话框，询问是否确认移除文件，如下所示：

点击"确定"，即可移除文件。点击"取消"，取消移除文件。

注意事项

无

相关链接


4.2.3 编译项目

文章内容

选择"Build"选项，在弹出的菜单里选择"Compile Project"，如下图所示：

或者点击小图标，如下：

编译正确后，在下面的输出框会有编译正确的提示，例如：

若编译不正确，会在此提示相应的错误信息。

注意事项

无

相关链接


4.2.4 链接项目

文章内容

点击"Build"选项，在弹出的菜单里选择"Compile All"，如下：

或者，点击小图标，如下：

链接正确后，在下面的输出框会有链接正确的提示，例如：

若链接出错，会在此提示相应的错误信息。

注意事项

无

相关链接


4.2.5 执行项目

文章内容

点击"Build"选项，在弹出的菜单中选择"Execute Control"，弹出如下对话框：

或者点击小图标：

需要选择相应的模块名对应的dll文件。比如：我们的模块名是hello_world，我们需要选择上图中的TTCN3hello_world.dll，然后点击"打开"。

文件在正确运行之后，在下面的提示框会出现如下提示：
----------------------
04/02/07 10:15:34
(1):245156:3528:TciStartControl
(2):245187:3528:ComponentValue con,name:Control
(3):245187:3528:CreateControl
(4):245187:3528:ComponentEntity():id:0,cAlive:0
(5):245187:2808:Value::Stop in Control
(6):245187:2808:ID:0,Entity::Stop
(7):245187:2808:Value::Kill in Control
(8):245187:2808:ID:0,Entity::Kill
(9):245187:2808:Throw KillEx with 0
(10):245187:3528:TciStartControl will end
(11):245187:2808:ControlRunnable::run,catch KillEx with id:0
(12):245187:2808:RemoveComponent:0
(13):245187:2808:~ComponentEntity,ID:0
(14):245187:2808:~CmpEntity() Thread:00000000
(15):245187:2808:TimerHolder::Remove() 0
(16):245187:2808:TimerHolder::Remove() 0
(17):245187:2808:TimerHolder::Remove() 0 not exist!
(18):245187:2808:ComponentValue des,name:Control
(19):245187:2808:ComponentHolder::Reset
(20):245187:2808:ComponentHolder::Reset 0 Cmps
(21):245187:2808:TimerHolder::Reset
(22):245187:2808:TimerHolder::Reset 0 timers
(23):245187:2808:Control Part End
----------------------
04/02/07 10:20:54
(1):565421:3528:TciStartControl
(2):565421:3528:ComponentValue con,name:Control
(3):565421:3528:CreateControl
(4):565421:3528:ComponentEntity():id:0,cAlive:0
(5):565421:3528:TciStartControl will end
(6):565421:2580:Value::Stop in Control
(7):565421:2580:ID:0,Entity::Stop
(8):565421:2580:Value::Kill in Control
(9):565421:2580:ID:0,Entity::Kill
(10):565421:2580:Throw KillEx with 0
(11):565421:2580:ControlRunnable::run,catch KillEx with id:0
(12):565437:2580:RemoveComponent:0
(13):565437:2580:~ComponentEntity,ID:0
(14):565437:2580:~CmpEntity() Thread:00000000
(15):565437:2580:TimerHolder::Remove() 0
(16):565437:2580:TimerHolder::Remove() 0
(17):565437:2580:TimerHolder::Remove() 0 not exist!
(18):565437:2580:ComponentValue des,name:Control
(19):565437:2580:ComponentHolder::Reset
(20):565437:2580:ComponentHolder::Reset 0 Cmps
(21):565437:2580:TimerHolder::Reset
(22):565437:2580:TimerHolder::Reset 0 timers
(23):565437:2580:Control Part End

注意事项

无

相关链接


4.2.6 查看执行结果

文章内容

在右侧的输出框会出现要输出的内容，如下所示：

注意事项

无

相关链接


第五章 FAQ

文章内容

注意事项

无

相关链接


第六章 修订记录

文章内容

注意事项

无

相关链接


第七章 版权信息

文章内容

版权所有(C) 2006--2010，中国科学技术大学网络安全实验室TTCN-3开发小组，保留所有权利。

注意事项

无

相关链接


Easy CHM - http://www.eTextWizard.com

您现在使用的CHM文件由Easy CHM的未注册版本制作.
注册版本不会在CHM里自动添加此页面

Easy CHM 软件 软件出品: 国华软件 中国北京 |  | 截屏图片
 | 文件大小: 1392k - 1.39MB | 软件类型: 共享软件 购买注册: 这里
关键词: make chm, create chm, chm制作工具, chm电子书制作工具,chm帮助文件制作工具

描述:

Easy CHM是国华软件推出的一款强大的CHM电子书或CHM帮助文件的快速制作工具。使用EasyCHM只需要三个步骤就可以完成CHM的制作：1、用户指定一个目录，EasyCHM会自动导入全部目录及文件；2、设置CHM编译选项；3、开始制作。EasyCHM非常适合个人和单位制作高压缩比的带有全文检索及高亮显示搜索结果的网页集锦、CHM帮助文件、产品说明、公司介绍、CHM电子书等等。

主要功能：

  • 全自动的目录及文件导入（可以包括子目录）；
  • 自动生成上下文相关的帮助文件直接供程序员使用；
  • 支持导入任意的文件类型；
  • 自动生成CHM的目录列表并自动生成所有目录项；
  • 为CHM的目录列表自动添加多级编号；
  • 批量更换CHM目录各项的图标；
  • 支持批量查找替换多级目录各项的标题文字内容；
  • 允许用户指定从文本文件的第N行自动截取标题；
  • 易用的目录编辑器；
  • 丰富实用的CHM制作选项帮助用户制作更加个性化的专业CHM电子书或CHM帮助文件。
  • 内嵌CHM反编译工具。
  • 用户可以保存和打开工程文件。

EasyCHM未注册版本的主要限制：

  1. EasyCHM的未注册版本可以制作带任意层级目录的CHM，但是每个CHM的工具栏上都会自动添加一个ABOUT按钮，以提醒用户注册。注册版本不会添加ABOUT按钮。
  2. EasyCHM的未注册版本无法保存CHM的通用工程文件，如*.HHP、*.HHC、*.HHK等，未注册版本的EasyCHM会自动删除*.HHP、*.HHC、*.HHK这几个文件。

注册版本无任何限制。
如果EasyCHM可以为您的工作和学习提供帮助，请注册购买，感谢您给予软件作者的支持。
联系方式:
国华软件站点一: http://www.etextwizard.com
国华软件站点二: http://www.zipghost.com
技术支持信箱: webmaster@etextwizard.com
购买方式:
在线购买:（可提供发票，支持很多种支付方式，包括邮政汇款）
单用户企业版 299元 人民币 ：通过“共享软件注册中心”购买

单用户家庭版 99元 人民币： 通过“共享软件注册中心”购买
直接向作者注册（共3种方式）：
1、招商银行划款:
开户行： 招商银行北京分行双榆树支行
帐 号： 001015570093
户 名： 冯国华
2、中国农业银行金穗卡转帐（注意是卡号）：
金穗卡卡号： 95599 8001 42061 34216
收 款 人： 冯国华
3、中国工商银行牡丹灵通卡转帐：

开户城市：北京
牡丹灵通卡卡号：9558 8202 0000 3186295 （注意是卡号9558820200003186295）
收 款 人： 冯国华

注意事项：
直接向作者注册的用户请在汇出足额的注册费后以EMAIL形式通知作者，同时请尽量提供

  • 汇款日期

  • 汇出城市

  • 汇出行

  • 汇款人姓名

  • 用于接收注册码的信箱（请确保可以接收邮件，最好多提供）

  • 您希望的注册用户名

  • 要注册的软件及套数

您提供的资料详细些会比较方便确认。
作者在确认支付已完成后将会马上发出注册码。
用户在收到注册信后请尽量给软件作者发个类似“已收到注册码”的确认信 - 感谢您的配合！
下载地址:

系统需求: Win98,WinME,WinXP,Windows2000
安装支持: 支持安装及卸载


1

文章内容

上图为TTCN3测试系统总体框架图，其中测试管理即为TTM的主要工作。

注意事项

无

相关链接


CHMFactory 帮助系统

4

文章内容

注意事项

无

相关链接


4

文章内容

TTCN3帮助文档

注意事项

无

相关链接


4.1

文章内容

刚开始打开TTM时，存在的四个菜单之一。

注意事项

无

相关链接


4.1

文章内容

Project菜单如上图所示，共有8项

注意事项

无

相关链接


打开、移除或新建项目

文章内容

注意事项

无

相关链接